Hello There, Guest! Login or Register


Sensitivity fix
#51
my bro has the same issue...thx for the thread xD
Reply
#52
So I tried reinstalling San Andreas and SAMP and I get this annoying y-axis sensitivity crap. Thank God this forum is still around. Didn't completely eliminate the issue but reduced it greatly. Thank you Slice of 6 years ago.
Reply
#53
I just solved this issue completely..
If anybody has the same problem, answere here and I will reply with the solution (no mood to upload and text a lot rn) :D
But yea..with the files in the first post, you can ONLY change the sensitivity to however you want, but it does NOT fix the xy axis problem..
Doesn't matter if you increase your sensitivity by 10 or 5..the y axis will still be more sensitive than x, so this is not the solution
Reply
#54
just got a quality guy to add a subscription for.. nice vids gonna watch them all
Reply
#55
(09-02-2017, 10:34 PM)[BkM]PwN3R_BoSs Wrote: I just solved this issue completely..
If anybody has the same problem, answere here and I will reply with the solution (no mood to upload and text a lot rn) :D
But yea..with the files in the first post, you can ONLY change the sensitivity to however you want, but it does NOT fix the xy axis problem..
Doesn't matter if you increase your sensitivity by 10 or 5..the y axis will still be more sensitive than x, so this is not the solution

I need help
Reply
#56
Just install the given programs and don't bother with arrows in-game.
Instead of this, go to the GTA SA folder where you installed all this and open "sensfix" folder, and type in numbers of any sensitivity that you want and it's done.
Reply
#57
I don't see where this would help since y will STILL be more sensitive than the x axis when you move the mouse..
If your solution works for you, then it looks like you don't really have this problem..

The problem is that some genius coders didn't equal the x and y axis so of course it doesn't work..
I don't have a compiler on my PC right now so I just provide the Code for the fix here:

Code:
#include <Windows.h>

DWORD WINAPI ThreadProc(
 _In_ LPVOID lpParameter
)
{
    Sleep(10000);

    float& fMouseAccelVertical = *(float *)0xB6EC18;
    float& fMouseAccelHorzntl = *(float *)0xB6EC1C;    
    
    for(;;)
    {
        fMouseAccelVertical = fMouseAccelHorzntl;
        Sleep(5);
    }
    return 0;
}

BOOL WINAPI DllMain(
 _In_ HINSTANCE hinstDLL,
 _In_ DWORD     fdwReason,
 _In_ LPVOID    lpvReserved
)
{
    if(fdwReason == DLL_PROCESS_ATTACH)
    {
        CreateThread(NULL, NULL, (LPTHREAD_START_ROUTINE)ThreadProc, NULL, NULL, NULL);
    }
    return 1;
}
Reply
#58
I used a fix that With steps that I posted before and X and Y axis have equal speed.
But before editing sensfix folder adjust the in-game sensitivity to 4 or 5 where x and y axis are approx. the same speed, then edit the sensfix folder.
Reply
#59
Man, the download link is unavailable, can you update it please? I really need it.
Reply